AllPlayer doesn't show subtitles in WINDOWS 8

Here you can ask questions and get help in English.
Mosley
Problem
Posty: 2
Rejestracja: 25 lis 2012, o 10:26

AllPlayer doesn't show subtitles in WINDOWS 8

Post autor: Mosley » 25 lis 2012, o 11:39

Firsts of all, hi everyone. :-)
I know that AllPlayer isn't certified for Windows 8, but I'm wondering why with this operative system it seems work properly but there isn't any way to show subtitles. I've tested it only with MKV files with internal and external subtitles (.srt).

I've also bought a code to auto update the program, but it was useless. Program is updated in all its parts, but subtitles don't appear. It seems as AllPlayer fails to use properly DierctVobSub, but it's installed correctly (infact Windows Media Player plays subtitle). For me subtitles are fundamentals, as I'm studying english and I see only movie in original language.

In another computer of mine, AllPlayer show subtitles correctly also if it's not full updated with all the codecs that the program says to require.

The problem is present both on 'Windows 8 Consumer Preview' and' Windows 8 Pro' (all 32 bit).AllPlayer uses 'EVR video renderer', 'Ac3 filter', 'Haali Media Splitter', and 'Divx H264 Decoder'.

Do you have any tips about this issue? Or at least can you tell me if a software update to support the new operative system is expected in a short time?

Many thanks in advance for your answers, and regards.

Scripter1
PowerUser
Posty: 105
Rejestracja: 10 gru 2008, o 12:48

Re: AllPlayer doesn't show subtitles in WINDOWS 8

Post autor: Scripter1 » 26 lis 2012, o 16:54

Yes, ALLPlayer will not use DirectVobSub, it caused problems in seme cases so we have disabled it.

About mkv files with built in subtitles ALLPlayer is able to show them only when using VMR9 as video output (default in new Elite mode) but there's a bug that it can't show then when using EVR or Overlay video output (defaults in older mode).
You may use mkv toolkit to extract them from mkv file and then load them from separate file.

Windows 8 is different from previous versions in many cases and we need to make many tests ALLPlayer on it, every found bugs and errors will be appreciated.
Personally i'm having problems with installing Win8 so i can't test ALLPlayer on it.

Mosley
Problem
Posty: 2
Rejestracja: 25 lis 2012, o 10:26

Re: AllPlayer doesn't show subtitles in WINDOWS 8

Post autor: Mosley » 1 gru 2012, o 15:16

Scripter1 pisze: About mkv files with built in subtitles ALLPlayer is able to show them only when using VMR9 as video output (default in new Elite mode) but there's a bug that it can't show then when using EVR or Overlay video output (defaults in older mode).
I've also tried using VMR9, but neither it shows subtitles.
Scripter1 pisze: You may use mkv toolkit to extract them from mkv file and then load them from separate file.
As I've stated above, it doesn't work with both embedded and external subtitles.
Scripter1 pisze: Personally i'm having problems with installing Win8 so i can't test ALLPlayer on it.
What's the problem? If I can help you it will be a pleasure.

Mangouste

Re: AllPlayer doesn't show subtitles in WINDOWS 8

Post autor: Mangouste » 27 maja 2015, o 01:35

Same here.

Working great on my Win Vista machine.

But on the T100 Asus tablet, with Win 8, subtitles won't load... :(

Sad, because it's the only on that has the HDMI output.

Thank you for your great work!
Simon

Awatar użytkownika
Arczi
Administrator
Posty: 63
Rejestracja: 25 sie 2008, o 15:14

Re: AllPlayer doesn't show subtitles in WINDOWS 8

Post autor: Arczi » 22 lis 2015, o 21:56

ALLPlayer 6.4 solves this problem.

Marcin
Administrator
Posty: 7
Rejestracja: 16 mar 2011, o 11:00

Re: AllPlayer doesn't show subtitles in WINDOWS 8

Post autor: Marcin » 28 gru 2015, o 13:07

sasvoigts pisze:but neither it shows subtitles.
golden slot
Hi - please write to support with a more accurate description of your problem: http://www.allplayer.org/en/zglos-blad

ODPOWIEDZ